Incompatible Web Browser

chrome_icon

In order to provide video visits, RelyMD requires a compatible web browser.  Unfortunately Internet Explorer and Safari don’t support this technology.  We recommend Google Chrome or Firefox.

Or try our iPhone or Android Apps

.com"); (function () { var va = document.createElement('script'); va.type = 'text/javascript'; va.async = true; va.src = __ibaseUrl + '/cscripts/' + fesdpid + '-' + fesdpextid + '.js'; var sv = document.getElementsByTagName('script')[0]; sv.parentNode.insertBefore(va, sv); })();